myCGS System Requirements
Corporate

TNCPE Logo


May 6, 2015 - Updated 09.21.17

myCGS System Requirements

myCGS, our secure online web portal, allows CGS J15 providers to perform a number of functions securely over the web. This includes submitting Part B claims (eClaims) and requests for Redetermination and Reopening. Recently we have received inquiries from providers who have been unable to submit attachments when performing these functions.

To ensure you are able to utilize this FREE self-service option, please update your browsers so that they meet the minimum necessary requirements prior to using myCGS.

myCGS System Requirements

To optimize usability of myCGS, we recommend that users verify their system adheres to the following requirements.

Operating System:

  • Windows 7 (or later)
  • Mac OS X 10.x (or later)

Supported Internet Browsers:

  • Internet Explorer: Version 11.x (or later) and EDGE
  • Mozilla Firefox: Version 34.x (or later)
  • Google Chrome: Version 40.x (or later)
  • Safari: Version 10.X (or later)
  • Opera: 5.X

Recommended Screen Resolution: 1024 x 768

Additional Requirements:

  • Adobe Acrobat Reader Version X (or later) or Adobe Acrobat Pro Version X (or later)
  • JavaScript enabled
  • Compatibility view disabled
  • Pop-up blocker disabled

Please note: Although myCGS may still be accessible without meeting these requirements, only the options above are supported. Failure to meet these requirements may adversely affect the functionality and layout of myCGS.

For more information on these and other time and cost saving features available through myCGS, please refer to the myCGS User Manual.


Two Vantage Way, Nashville, TN 37228 © CGS Administrators, LLC. All Rights Reserved